How to Fix your Cuisinart SS-10 Keurig Coffee Machine (or any Keurig Machine)



Head to BrieOCD.com to find out how to fix/troubleshoot any Keurig coffee machine! I take you step-by-step on how to get your machine back up and running!

13 Comments

  1. Great Advice I started using “Brew Rite” which had worked in the past .After running a cycle of that Mixture, I still was not getting hot water or Brew to work. I took your advice on Descaling …the 50-50 mix of vinegar and water and ran through rinse several times it was now working . I alternated between hot water & Brew and continued until all the vinegar smell was gone . Thank you.

  2. That is an SS700, I had one still in the backyard, I loved it anyway but it is dead, now I have the SS 10 and it is working but the descale message won't go away I descaled three times now, doing every step you said and nothing. Do you know have to get rid of the descale message?

  3. After watching this video, I realized that I had forgotten to clean out the upper needle in my iCoffee coffee maker when I was cleaning & descaling it this morning. Whipped out a paper clip, cleaned that needle, and my iCoffee is now brewing full-sized cups again. I may not have to upgrade to a Cuisinart SS-10 yet after all!

  4. I have the exact same model and mine says not ready when it's plugged in. I've tried everything and it's not moving from that status. I can tell something is brewing because after a minute it's getting very hot. Think it's done?

  5. Good, but question: where does the water go when you use the ‘rinse’ feature? It must use water to rinse… but I can’t figure out if it goes somewhere or is such a small amount that it evaporates?

Leave a Reply

Your email address will not be published.


*